2018
21.12
PHP – support for PHP 5.6 and PHP 7.0 ends

No more security updates: Security support for PHP 5.6 will expire on December 31, 2018. For PHP 7.0 that was already the case on the 3rd of December. Website admins should act immediately and switch to a current PHP version. In a timeline on the PHP website you can see how much longer there is support for different PHP issues. The PHP developers distinguish between active support and security support. For example, PHP 7.1 has not been in active support for about a year, but will receive security updates by December 2019.

The problem is that millions of websites are no longer using security support for PHP versions. For example, the widely used WordPress content management system still supports PHP 5.2, which has been out of production for almost eight years. According to the statistics service W3Techs, almost 79 percent of all websites currently use PHP. Version 5 is still used in about 59 percent of these pages. But things are progressing: in October, that was still the case with 78 percent. For their statistics, W3Techs claims to inter alia evaluate data from 10 million websites that come from analytics service Alexa.

back